#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-fA-F0-9]{64}$"
Local $sString = "md5" & @CRLF & _
"66682880b58943ac2358aa5416a5880f" & @CRLF & _
"f0b7fdf47863b4d6d018e35c25c66169" & @CRLF & _
"8f57434b9a58fbbe29c999df50ffecc2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"sha1" & @CRLF & _
"10886660c5b2746ff48224646c5094ebcf88c889" & @CRLF & _
"7b650a8ce213738d38b60ee9d99ffae8def286e5" & @CRLF & _
"4e9429cec96a08face2c8deeb01c27228b725ed2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"sha256" & @CRLF & _
"746df05c8f3a0b07a46c0967cfbc5cbe5b9d48d0f79b6177eeedf8be6c8b34b5" & @CRLF & _
"a1efca12ea51069abb123bf9c77889fcc2a31cc5483fc14d115e44fdf07c7980" & @CRLF & _
"a1f0b78b8c1320690327800e3a5de10e7dbba7b6c752e702193a395a52c727b6" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"test" & @CRLF & _
"f more" & @CRLF & _
"a1f0b78b8c1320690327800e3a5de10e7dbba7grtgrtc752e702193a395a5w2c7b6" & @CRLF & _
"" & @CRLF & _
"a1f0b78b8c1320690327800e3a5de10e7dbba7b6c752e702193a395a52c7" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")