$re = '/^[a-fA-F0-9]{64}$/m';
$str = 'md5
66682880b58943ac2358aa5416a5880f
f0b7fdf47863b4d6d018e35c25c66169
8f57434b9a58fbbe29c999df50ffecc2
sha1
10886660c5b2746ff48224646c5094ebcf88c889
7b650a8ce213738d38b60ee9d99ffae8def286e5
4e9429cec96a08face2c8deeb01c27228b725ed2
sha256
746df05c8f3a0b07a46c0967cfbc5cbe5b9d48d0f79b6177eeedf8be6c8b34b5
a1efca12ea51069abb123bf9c77889fcc2a31cc5483fc14d115e44fdf07c7980
a1f0b78b8c1320690327800e3a5de10e7dbba7b6c752e702193a395a52c727b6
test
f more
a1f0b78b8c1320690327800e3a5de10e7dbba7grtgrtc752e702193a395a5w2c7b6
a1f0b78b8c1320690327800e3a5de10e7dbba7b6c752e702193a395a52c7
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);