# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-fA-F0-9]{64}$"
test_str = ("md5\n"
"66682880b58943ac2358aa5416a5880f\n"
"f0b7fdf47863b4d6d018e35c25c66169\n"
"8f57434b9a58fbbe29c999df50ffecc2\n\n\n"
"sha1\n"
"10886660c5b2746ff48224646c5094ebcf88c889\n"
"7b650a8ce213738d38b60ee9d99ffae8def286e5\n"
"4e9429cec96a08face2c8deeb01c27228b725ed2\n\n\n\n"
"sha256\n"
"746df05c8f3a0b07a46c0967cfbc5cbe5b9d48d0f79b6177eeedf8be6c8b34b5\n"
"a1efca12ea51069abb123bf9c77889fcc2a31cc5483fc14d115e44fdf07c7980\n"
"a1f0b78b8c1320690327800e3a5de10e7dbba7b6c752e702193a395a52c727b6\n\n\n\n"
"test\n"
"f more\n"
"a1f0b78b8c1320690327800e3a5de10e7dbba7grtgrtc752e702193a395a5w2c7b6\n\n"
"a1f0b78b8c1320690327800e3a5de10e7dbba7b6c752e702193a395a52c7\n\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.