$re = '/\"([^|]+)/m';
$str = '"AbCd1234|99999"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;