import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(if( |\\t)+\\(\\w+(?<!=<>!))=((?!=<>!)\\w+\\))";
final String string = " if (InvertX=1){\n"
+ " // Считываем задом-наперёд";
final String subst = "$1==$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}