$re = '/(if( |\t)+\(\w+(?<!=<>!))=((?!=<>!)\w+\))/m';
$str = ' if (InvertX=1){
// Считываем задом-наперёд';
$subst = "$1==$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;