use strict;
my $str = ' if (InvertX=1){
// Считываем задом-наперёд';
my $regex = qr/(if( |\t)+\(\w+(?<!=<>!))=((?!=<>!)\w+\))/mp;
my $subst = '$1==$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";