using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"blue dog(?! sleeping)";
string input = @"this is a blue dog
this is a blue dog sleeping";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}