$re = '/blue dog(?! sleeping)/m';
$str = 'this is a blue dog
this is a blue dog sleeping';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);