re = /blue dog(?! sleeping)/m
str = 'this is a blue dog
this is a blue dog sleeping'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end