#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\W|^)(HC|CAS)(\W|$)"
Local $sString = "0*1***HHCM" & @CRLF & _
"HC:83*20" & @CRLF & _
"HC:5*2CASL" & @CRLF & _
"DM*72" & @CRLF & _
"CAS*" & @CRLF & _
"HC:564*CAS*5" & @CRLF & _
"DM*72" & @CRLF & _
"CAS5*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")