$re = '/(\W|^)(HC|CAS)(\W|$)/m';
$str = '0*1***HHCM
HC:83*20
HC:5*2CASL
DM*72
CAS*
HC:564*CAS*5
DM*72
CAS5*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);