const regex = new RegExp('(\\W|^)(HC|CAS)(\\W|$)', 'gm')
const str = `0*1***HHCM
HC:83*20
HC:5*2CASL
DM*72
CAS*
HC:564*CAS*5
DM*72
CAS5*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}