using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s?\d\s?)(\s?\1){2,}";
string input = @"611 1 1256 8856 55 55
2 3 3 3 3 11 222 0 1 2 88 8 811";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}