const regex = /(\s?\d\s?)(\s?\1){2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s?\\d\\s?)(\\s?\\1){2,}', 'gm')
const str = `611 1 1256 8856 55 55
2 3 3 3 3 11 222 0 1 2 88 8 811`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}