re = /(\s?\d\s?)(\s?\1){2,}/m
str = '611 1 1256 8856 55 55
2 3 3 3 3 11 222 0 1 2 88 8 811'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end