#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?= # inside lookahead for overlapping results" & @CRLF & _
" (?<![^a]) # match at beginning of str or after a" & @CRLF & _
" (b*ab*) # one a between any number of bs" & @CRLF & _
" (?![^a]) # at end of str or before next a" & @CRLF & _
")"
Local $sString = "abbabb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")