re = /(?= # inside lookahead for overlapping results
(?<![^a]) # match at beginning of str or after a
(b*ab*) # one a between any number of bs
(?![^a]) # at end of str or before next a
)/mx
str = 'abbabb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end