import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?= # inside lookahead for overlapping results\n"
+ " (?<![^a]) # match at beginning of str or after a\n"
+ " (b*ab*) # one a between any number of bs\n"
+ " (?![^a]) # at end of str or before next a\n"
+ ")";
final String string = "abbabb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}