package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'((?:[^']+|'')*)'`)
var str = `The quick 'brown fox ''jumped ''''over the lazy dog''' and 'one more';`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}