$re = '/\'((?:[^\']+|\'\')*)\'/m';
$str = 'The quick \'brown fox \'\'jumped \'\'\'\'over the lazy dog\'\'\' and \'one more\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);