re = /'((?:[^']+|'')*)'/m
str = 'The quick \'brown fox \'\'jumped \'\'\'\'over the lazy dog\'\'\' and \'one more\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end