#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\/\/.+$|/\*[^*]*\*+(?:[^/*][^*]*\*+)*/)|(\"[^\"]*\"|\'[^']*\')"
Local $sString = "// this is an inline comment with the name "Alpha 1"" & @CRLF & _
"" & @CRLF & _
"string x = "Alpha 2";" & @CRLF & _
"/** this is a block comment with the string "Alpha 3" */" & @CRLF & _
"foo("Alpha 4");" & @CRLF & _
"string y = "Alpha /* */ 5 // with comments";"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")