package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\/\/.+$|/\*[^*]*\*+(?:[^/*][^*]*\*+)*/)|(\"[^\"]*\"|\'[^']*\')`)
var str = `// this is an inline comment with the name "Alpha 1"
string x = "Alpha 2";
/** this is a block comment with the string "Alpha 3" */
foo("Alpha 4");
string y = "Alpha /* */ 5 // with comments";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}