using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\/\/.+$|/\*[^*]*\*+(?:[^/*][^*]*\*+)*/)|(\""[^\""]*\""|\'[^']*\')";
string input = @"// this is an inline comment with the name ""Alpha 1""
string x = ""Alpha 2"";
/** this is a block comment with the string ""Alpha 3"" */
foo(""Alpha 4"");
string y = ""Alpha /* */ 5 // with comments"";";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}