#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*([[:alnum:]_.+-]+)\.([[:alnum:]_+-]+)\s+([[:alnum:]._+~-]+)\.([[:alpha:]]+[[:digit:]]+)"
Local $sString = "libtool.x86_64 2.4.6-8.cm2 @System" & @CRLF & _
"libxml2.x86_64 2.10.3-1.cm2 @System" & @CRLF & _
"libxml2-devel.x86_64 2.10.3-1.cm2 @System" & @CRLF & _
"lua.x86_64 5.4.4-1.cm2 @System" & @CRLF & _
"lua-libs.x86_64 5.4.4-1.cm2 @System" & @CRLF & _
"m4.x86_64 1.4.19-1.cm2 @System" & @CRLF & _
"make.x86_64 4.3-2.cm2 @System" & @CRLF & _
"mariner-check-macros.noarch 2.0-21.cm2 @System" & @CRLF & _
"mariner-repos.noarch 2.0-8.cm2 @System" & @CRLF & _
"mariner-repos-shared.noarch 2.0-8.cm2 @System" & @CRLF & _
"mariner-rpm-macros.noarch 2.0-21.cm2 @System" & @CRLF & _
"mpfr.x86_64 4.1.0-1.cm2 @System" & @CRLF & _
"mpfr-devel.x86_64 4.1.0-1.cm2 @System" & @CRLF & _
"msopenjdk-11.x86_64 11.0.18-1 @System" & @CRLF & _
"ncurses.x86_64 6.4-1.cm2 @System" & @CRLF & _
"ncurses-compat.x86_64 6.4-1.cm2 @System" & @CRLF & _
"ncurses-devel.x86_64 6.4-1.cm2 @System" & @CRLF & _
"ncurses-libs.x86_64 6.4-1.cm2 @System" & @CRLF & _
"ncurses-term.x86_64 6.4-1.cm2 @System" & @CRLF & _
"newt.x86_64 0.52.21-4.cm2 @System" & @CRLF & _
"newt-lang.x86_64 0.52.21-4.cm2 @System" & @CRLF & _
"nghttp2.x86_64 1.46.0-2.cm2 @System" & @CRLF & _
"npth.x86_64 1.6-4.cm2 @System" & @CRLF & _
"openssl.x86_64 1.1.1k-24.cm2 @System" & @CRLF & _
"openssl-devel.x86_64 1.1.1k-24.cm2 @System"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")