import re
regex = re.compile(r"^\s*([[:alnum:]_.+-]+)\.([[:alnum:]_+-]+)\s+([[:alnum:]._+~-]+)\.([[:alpha:]]+[[:digit:]]+)", flags=re.MULTILINE)
test_str = ("libtool.x86_64 2.4.6-8.cm2 @System\n"
"libxml2.x86_64 2.10.3-1.cm2 @System\n"
"libxml2-devel.x86_64 2.10.3-1.cm2 @System\n"
"lua.x86_64 5.4.4-1.cm2 @System\n"
"lua-libs.x86_64 5.4.4-1.cm2 @System\n"
"m4.x86_64 1.4.19-1.cm2 @System\n"
"make.x86_64 4.3-2.cm2 @System\n"
"mariner-check-macros.noarch 2.0-21.cm2 @System\n"
"mariner-repos.noarch 2.0-8.cm2 @System\n"
"mariner-repos-shared.noarch 2.0-8.cm2 @System\n"
"mariner-rpm-macros.noarch 2.0-21.cm2 @System\n"
"mpfr.x86_64 4.1.0-1.cm2 @System\n"
"mpfr-devel.x86_64 4.1.0-1.cm2 @System\n"
"msopenjdk-11.x86_64 11.0.18-1 @System\n"
"ncurses.x86_64 6.4-1.cm2 @System\n"
"ncurses-compat.x86_64 6.4-1.cm2 @System\n"
"ncurses-devel.x86_64 6.4-1.cm2 @System\n"
"ncurses-libs.x86_64 6.4-1.cm2 @System\n"
"ncurses-term.x86_64 6.4-1.cm2 @System\n"
"newt.x86_64 0.52.21-4.cm2 @System\n"
"newt-lang.x86_64 0.52.21-4.cm2 @System\n"
"nghttp2.x86_64 1.46.0-2.cm2 @System\n"
"npth.x86_64 1.6-4.cm2 @System\n"
"openssl.x86_64 1.1.1k-24.cm2 @System\n"
"openssl-devel.x86_64 1.1.1k-24.cm2 @System")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")