const regex = new RegExp('^\\s*([[:alnum:]_.+-]+)\\.([[:alnum:]_+-]+)\\s+([[:alnum:]._+~-]+)\\.([[:alpha:]]+[[:digit:]]+)', 'gm')
const str = `libtool.x86_64 2.4.6-8.cm2 @System
libxml2.x86_64 2.10.3-1.cm2 @System
libxml2-devel.x86_64 2.10.3-1.cm2 @System
lua.x86_64 5.4.4-1.cm2 @System
lua-libs.x86_64 5.4.4-1.cm2 @System
m4.x86_64 1.4.19-1.cm2 @System
make.x86_64 4.3-2.cm2 @System
mariner-check-macros.noarch 2.0-21.cm2 @System
mariner-repos.noarch 2.0-8.cm2 @System
mariner-repos-shared.noarch 2.0-8.cm2 @System
mariner-rpm-macros.noarch 2.0-21.cm2 @System
mpfr.x86_64 4.1.0-1.cm2 @System
mpfr-devel.x86_64 4.1.0-1.cm2 @System
msopenjdk-11.x86_64 11.0.18-1 @System
ncurses.x86_64 6.4-1.cm2 @System
ncurses-compat.x86_64 6.4-1.cm2 @System
ncurses-devel.x86_64 6.4-1.cm2 @System
ncurses-libs.x86_64 6.4-1.cm2 @System
ncurses-term.x86_64 6.4-1.cm2 @System
newt.x86_64 0.52.21-4.cm2 @System
newt-lang.x86_64 0.52.21-4.cm2 @System
nghttp2.x86_64 1.46.0-2.cm2 @System
npth.x86_64 1.6-4.cm2 @System
openssl.x86_64 1.1.1k-24.cm2 @System
openssl-devel.x86_64 1.1.1k-24.cm2 @System`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}