package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<first1>\w+)[ ](?P<last1>\w+)|(?P<last2>\w+),[ ](?P<first2>\w+)`)
var str = `"first_name last_name" or "last_name, first_name"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}