const regex = new RegExp('(?P<first1>\\w+)[ ](?P<last1>\\w+)|(?P<last2>\\w+),[ ](?P<first2>\\w+)', 'gm')
const str = `"first_name last_name" or "last_name, first_name"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}