#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.{7,}$)[a-z](?:[a-z_]*[a-z])*$"
Local $sString = "a" & @CRLF & _
"ab" & @CRLF & _
"a_b" & @CRLF & _
"abc" & @CRLF & _
"ex_bar" & @CRLF & _
"" & @CRLF & _
"_exbar" & @CRLF & _
"exbar_" & @CRLF & _
"_test_" & @CRLF & _
"abcdefgb"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")