using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.{7,}$)[a-z](?:[a-z_]*[a-z])*$";
string input = @"a
ab
a_b
abc
ex_bar
_exbar
exbar_
_test_
abcdefgb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}