$re = '/^(?!.{7,}$)[a-z](?:[a-z_]*[a-z])*$/m';
$str = 'a
ab
a_b
abc
ex_bar
_exbar
exbar_
_test_
abcdefgb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);