package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(.[0-9,]+)\]`)
var str = `[,][123,1][,][456,2][,][789,3][,][,][,][,][,][,][,][,]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}