re = /\[(.[0-9,]+)\]/
str = '[,][123,1][,][456,2][,][789,3][,][,][,][,][,][,][,][,]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end