$re = '/^[a-z0-9._%+-]+@[a-z0-9.-]+?(?:\.com|\.org|\.co\.uk|\.org\.uk)$/m';
$str = 'sdhdhh@gmail.com
sdhdhh@gmail.co.uk
sdhdhh@gmail.org
sdhdhh@gmail.org.uk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);