$re = '/\S(?:\s*\S){6}|(?:\S\s*){,6}$/';
$str = 'the quick brown fox jumps over the lazy doggo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);