re = /\S(?:\s*\S){6}|(?:\S\s*){,6}$/
str = 'the quick brown fox jumps over the lazy doggo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end