using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""([^""]*)""|'([^']*)'";
string input = @"This ""searchword1"". searchword. ""search 'word' 2""
This ""searchword3"". searchword. ""search 'word' 4""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}