$re = '/"([^"]*)"|\'([^\']*)\'/m';
$str = 'This "searchword1". searchword. "search \'word\' 2"
This "searchword3". searchword. "search \'word\' 4"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);