re = /"([^"]*)"|'([^']*)'/m
str = 'This "searchword1". searchword. "search \'word\' 2"
This "searchword3". searchword. "search \'word\' 4"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end