using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:_?\d_?){1,10}$)\d{0,5}_?\d{0,5}$";
string input = @"1_2
1_
_123
45_
12345_67890
123456_7890
1234567_789
12345_678901
1234A
12345
1234567890
0123456789
12_45_56
12_45
-678901
_
_1111111111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}