# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=(?:_?\d_?){1,10}$)\d{0,5}_?\d{0,5}$"
test_str = ("1_2\n"
"1_\n"
"_123\n"
"45_\n"
"12345_67890\n"
"123456_7890\n"
"1234567_789\n"
"12345_678901\n"
"1234A\n"
"12345\n"
"1234567890\n"
"0123456789\n"
"12_45_56\n"
"12_45\n"
"-678901\n"
"_\n"
"_1111111111")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.