const regex = /^(?=(?:_?\d_?){1,10}$)\d{0,5}_?\d{0,5}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:_?\\d_?){1,10}$)\\d{0,5}_?\\d{0,5}$', 'gm')
const str = `1_2
1_
_123
45_
12345_67890
123456_7890
1234567_789
12345_678901
1234A
12345
1234567890
0123456789
12_45_56
12_45
-678901
_
_1111111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}