#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^(?:(?:Lung|LUNG) RADS:?(?: CATEGORY:?| [cC]ategory:?)? ?|LUNGRADS? |LUNG-RAD ))(?:\d[A-Z]?|[A-Z])(?![A-Z])"
Local $sString = "LUNG RADS CATEGORY 2" & @CRLF & _
"Lung RADS category 1, " & @CRLF & _
"Lung RADS category 2. " & @CRLF & _
"LUNG RADS CATEGORY 1:" & @CRLF & _
"Lung RADS 3S." & @CRLF & _
"Lung RADS Category 1:" & @CRLF & _
"Lung RADS Category 1 (S):" & @CRLF & _
"LUNG RADS CATEGORY 1 S" & @CRLF & _
"Lung RADS category: 2S." & @CRLF & _
"Lung RADS: 2C" & @CRLF & _
"Lung RADS category 4B," & @CRLF & _
"Lung RADS category 1S." & @CRLF & _
"Lung RADS: 3." & @CRLF & _
"Lung RADS category I" & @CRLF & _
"Lung RADS 2" & @CRLF & _
"LUNG RADS CATEGORY:I" & @CRLF & _
"LUNGRADS 2" & @CRLF & _
"LUNGRAD 2" & @CRLF & _
"LUNG-RAD 3" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")