# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^(?:(?:Lung|LUNG) RADS:?(?: CATEGORY:?| [cC]ategory:?)? ?|LUNGRADS? |LUNG-RAD ))(?:\d[A-Z]?|[A-Z])(?![A-Z])"
test_str = ("LUNG RADS CATEGORY 2\n"
"Lung RADS category 1, \n"
"Lung RADS category 2. \n"
"LUNG RADS CATEGORY 1:\n"
"Lung RADS 3S.\n"
"Lung RADS Category 1:\n"
"Lung RADS Category 1 (S):\n"
"LUNG RADS CATEGORY 1 S\n"
"Lung RADS category: 2S.\n"
"Lung RADS: 2C\n"
"Lung RADS category 4B,\n"
"Lung RADS category 1S.\n"
"Lung RADS: 3.\n"
"Lung RADS category I\n"
"Lung RADS 2\n"
"LUNG RADS CATEGORY:I\n"
"LUNGRADS 2\n"
"LUNGRAD 2\n"
"LUNG-RAD 3\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.