import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^(?:(?:Lung|LUNG) RADS:?(?: CATEGORY:?| [cC]ategory:?)? ?|LUNGRADS? |LUNG-RAD ))(?:\\d[A-Z]?|[A-Z])(?![A-Z])";
final String string = "LUNG RADS CATEGORY 2\n"
+ "Lung RADS category 1, \n"
+ "Lung RADS category 2. \n"
+ "LUNG RADS CATEGORY 1:\n"
+ "Lung RADS 3S.\n"
+ "Lung RADS Category 1:\n"
+ "Lung RADS Category 1 (S):\n"
+ "LUNG RADS CATEGORY 1 S\n"
+ "Lung RADS category: 2S.\n"
+ "Lung RADS: 2C\n"
+ "Lung RADS category 4B,\n"
+ "Lung RADS category 1S.\n"
+ "Lung RADS: 3.\n"
+ "Lung RADS category I\n"
+ "Lung RADS 2\n"
+ "LUNG RADS CATEGORY:I\n"
+ "LUNGRADS 2\n"
+ "LUNGRAD 2\n"
+ "LUNG-RAD 3\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}