# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/m\d\b|(\d*[,.]?\d+)|[^0-9.*\/()+\n-]+/$1/g;t' <<< "=(3m2*3m)*2/10worker
=(0,3m2*3m)*2/10worker
=(0.3m2*3m)*2/10worker"