package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`m\d\b|(\d*[,.]?\d+)|[^0-9.*/()+\n-]+`)
var str = `=(3m2*3m)*2/10worker
=(0,3m2*3m)*2/10worker
=(0.3m2*3m)*2/10worker`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}