using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"m\d\b|(\d*[,.]?\d+)|[^0-9.*/()+\n-]+";
string substitution = @"$1";
string input = @"=(3m2*3m)*2/10worker
=(0,3m2*3m)*2/10worker
=(0.3m2*3m)*2/10worker";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}